Start a new topic

Accessing Context Menu in KS 9.1.98 with single button mouse

For reasons that aren't worth getting into here, I do not use a two button mouse with a right click/left click. I'm on a Mac and use a single button mouse and set it so that both sides are equal to a left click. To simulate a right click, I hold down the CONTROL key. This has never been a problem in previous versions of KeyShot when accessing the context menu in the realtime window. In version 9 it does not work. I can see in the hotkey defaults settings that context menu is set to RMB. When I use CONTROL + click anywhere else in KS9 to simulate a right click (such as in the scene tree or in the material graph) it works. So, KS9 seems to recognize CONTROL + click as a substitute for RMB but not in the real time window. This is a problem for me. This seems like a bug. 

Hello, what type of mouse and what are the specs of your Mac?

Does this issue effect all single-button mouse controllers or just one specific model?

Hi Erik


The mouse I’m using is the Apple Mighty Mouse (


While this isn’t technically a “single button” mouse (it can be used as a left click/right click mouse) I set it to be single click. As you may (or may not) remember, all Mac mice (back in the day) were single button only and it’s what I got used to. I position my hand in such a way that what is a left click, for me, would be a right click for anyone else. I’ve tried setting the mouse to be a two button but it results in normal “right click” menus popping up all the time when I don’t want them to. It’s pretty annoying. That’s why I opt for holding down control to simulate the right click. It works like a charm and as I mentioned in my initial post this has never been an issue in KeyShot, going back to version 6 when I started using it. And even in the current version (9.3) it works everywhere that it should except in the real time window to bring up the context menu (which started happening in 9.0). It definitely slows me down. I’ve tried to work around this by setting a custom hot key to left click+alt (to simulate the right click in the real time window) and I’m sure I can get used to that with time but it would be great if it worked the way it’s supposed to. 


This is the only “single button” mouse I’ve tried it with. To be honest, I’m not even sure they are any others out there still being made.


I’ve tried this on a couple of iMac models and the issue persists on both.


They are:

Currently running Mojave

Currently running High Sierra


Thanks for continuing to look into this and for following up.

I don’t think it’s going to make a difference but I accidentally mixed up the OS’s on the two iMacs I listed above. The 2015 model is running High Sierra and the 2012 model is running Mojave. I would have edited the previous post but this system doesn’t allow for it.

After some testing, it does seem to be an error in the platform.

I will have our team look into this now and see if we can get it patched for the next major release.

Thank you for bringing this to our attention. When the issue has been solved we will notify all of our customers in the patched versions release notes.

Thank you for your patience while we work on this matter.

Login to post a comment