Start a new topic

Creating huge renders (95000x20000px)

In my experimenting fase I'm trying to make a really big render and see if that works. I wanted to see if it can be done.

It's  a wall from 12m x 2.80m which makes around 95000x20000px image at 200dpi.

I just made a region render just to see what the quality would actually be. While the render works well (I think). The problem is the file saving.

If I click the green 'done' icon in the render window the finishing takes a really long time. Which is ok but a bit weird. Then I've a locked PSD file from 7.96GB which looks ok but it's locked (by keyshot).

Than when I click all away I see Keyshot has a dialog with 'saving 16%' but also a dialog from the auto save function which is out of focus and I can't click it. The saving 16% dialog stays at 16%.

So all in all I think it has the render capabilities but the file handling goes wrong. I know it's a terribly big image but saving it should give the least problems I would say.

Also, I tried this before with more render passes and an output to a PSD 16bit and once PSD 32bit and after about 45 minutes all I got was a PSD with 862bytes.

Maybe there are some tricks I can try but this is more a feedback post to inform you there are some issues with the file handling I think. Rendering a big image is no problem I think but the saving is.

I know V-Ray for example has a render to file option so it directly writes to the file instead of after the render. That can be a big help with large files. Also maybe the PSB option might be a thing to consider as output. I'm not sure how much it differs from a normal PSD but the PSB format is the 'Large Photoshop Document' format.

While typing that could be the issue since I think the PSD's can't have a file size over a certain size (at least I remember getting that warning sometimes).

At least I hope my feedback is worth something for the continuing perfection of Keyshot!

Version of Keyshot is 9.3, working at an i9 9900 with 64GB of ram (which Keyshot uses nicely :D)

What I just found out... if you click the render button it keeps an active button. So what I also did was to click it again which makes it an inactive button.

But it also tries to render another time with the same file name so under the render dialog there is a 'file already exists' dialog which you can't reach but you can see it using alt-tab.

Hello Oscar,

Thank you for contacting Luxion.
So you are correct on this, PSD are locked to 2G file sizes, so it looks like you are running in to limitations on that end with a render this size.
I would try render as a PNG see if that helps with the file size lock.

As far as the save time, KeyShot while rendering will save the data to a temp folder.  Once the render is done it will then push the render to the designated folder you chose to save it to.

​Also if you are saving on a network drive this will also add some time to the save process.
I will run some test renders on my end to collect more data on this.

Referencing your Ticket ID#:7600


Justin Adams
Support manager
Luxion Inc
15143 Woodlawn Ave
Tustin, CA 92780
Phone: (949) 274-8871
Fax: (949) 266-9523

Thanks for getting back to me Justin!

I wonder if you have the same with big renders. I just tried a square region from about 5k x 5k just to check how the quality would be. Output was .exr this time since I think those don't have the PSD limits as well.

After 6 passes I decided to stop the render so it asked if I wanted to stop or save and stop. I selected stop. Than it starts with the window 'finishing..' and it takes around 15 minutes for it disappear while the actual render 6 render passes took around 2 minutes.

When the 'finishing' window went away Keyshot was stuck in 'not responding'. 

SInce I'm using an Samsung EVO 970 SSD for the temp and final directory I don't think writing to disk is the issue. While rendering I see disk activity so it does indeed write to file while rendering. When the 'finishing...' appears the memory use of KeyShot gets lower and CPU usage is around 10%. Currently KeyShot is stuck for 15 minutes and I don't think it will wake up again ;)

I wonder if you get the same if you abort a (region)render. So a long appearance of the 'finishing' window and than a non responsive KeyShot.

You guys have beast PC's so wonder if that makes a difference. Another thing I was thinking of was the virtual Windows memory. I see that Windows currently allocated 100GB (!) but that's at drive D (SSD as well) so shouldn't interfere much and I didn't get a certain warning at a moment my D was running low at space.

Hope this helps a bit to replicate the behaviour.

Login to post a comment