Start a new topic

square artifacts (in interior mode?)

Hi folks,

i encountered some issues with an animation. Out of 101 frames 46 look like the attached one. They get seemingly inverse coloured square artifacts all over. The attached one is the worst of them all, some are artifacted to a lesser degree or more monochromatic. In final render output the squares on most images get black, but in the viewport or render preview they are always colourful like shown.

up on request i could share the .ksp - but i as well opened a support ticked where i attached the .ksp for the luxion team

there are 5 physical light sources: an area light + a spotlight, both animated with a fade curve and colour fade. The Spotlights poition is animated as well. And 3 area lights static in the light. Turning all animations off provided the same results.

its rendered without caustics, in interior mode. 30 samples with denoise at .4 . The Artifacts get worse with more samples though. And they do seem to not appear in product mode.


MacPro 2019

MacOS 10.15.4

Keyshot 9.3.14

AMD Radeon 580X Pro 

Intel Xeon

1 person has this question

Same for me,

iMac 2020 i9 10 cores

Radeon Pro 5700 XT 16GB

On my side, the issue does not affect final renders but viewport only (some renders fired, not a deep test, but they are fine).  It starts about around 30 samples as Sam say above. The issue does not affect my old (vintage) machines, Mac Pro and MacBook Pro Running KS under Mac OS High Sierra.

Both have a obsolete AMD Radeon Graphics card.

When I've experienced this issue on my new iMac in September  I thought it was related to a known 5700 XT 16GB driver issue recently fixed by Apple in last Catalina update...

GB (Radeon Pro 5700 XT) GDDR6

16 GB (Radeon Pro 5700 XT) GDDR6

same here:

iMac Pro 2017

2,5 GHz 14-Core Intel Xeon W

Radeon Pro Vega 64 16GB

worked fine on iMac but no longer on iMac Pro.

Interior mode and area/emissive light may cause problems...

Any news yet?


Hello, I get these black squares when rendering too. The squares are created when calculating the 2nd sample in export mode - not in live rendering.  The squares has dimension of 16x16 pixels. Where there are no objects in the picture there will be no squares (see left marginal are of screenshots). if I start the render job several times, the squares always appear at different (random?) positions and sometimes not at all. If I reduce the number of cores, more black squares will be calculated (see 2nd Screenshot).  If I reduce ray-bounces to zero there are no squares.

My Hardware:
Mac Pro 2019 16 Core Xeon W3245
AMD Radeon Pro W5700X 16GB
Lightning: Interior
Keyshot actual version

My ideas: Intel Xeon TurboBoost Max 3.0 drives CPU-cores at different speeds - so some segments are not ready when others are finished? Especially when calculating ray-bounces?

Hello Jonathan,

Thank you for contacting Luxion.
This issue has only been seen on macOS, and has FINALLY been solved in the KeyShot 10 release.

I would recommend contacting our Sales Department at and explain to them the situation. This is a serious bug and our customers should not be punished for it. A Sales representative will do everything they can to get you updated to KeyShot 10.

Thank you for your patience during all of this.
If there is anything we can do for you in Support to help, please let me know 

Referencing your Ticket ID#:11042


Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

1 person likes this

Hi Erik, thanks a lot erik for your help.

I really appreciate your effort in this long lasting journey ;) 

also have this issue but the squares are black.


i am on a MacBook Pro with BigSur and on a floating license of Keyshot 9

any help would be appreciated.

This is solved in Version 10!

thanks for the update - crossing fingers that this is true :)

i will let you know if this persists once i have V10 installed and running.


I updatet to Vs10 and the artifacts are gone. (Mac Pro 2019) A great update in functionality too. Support for 3dconnexion spacemouse is added too.

Login to post a comment