Start a new topic

square artifacts (in interior mode?)

Hi folks,

i encountered some issues with an animation. Out of 101 frames 46 look like the attached one. They get seemingly inverse coloured square artifacts all over. The attached one is the worst of them all, some are artifacted to a lesser degree or more monochromatic. In final render output the squares on most images get black, but in the viewport or render preview they are always colourful like shown.

up on request i could share the .ksp - but i as well opened a support ticked where i attached the .ksp for the luxion team

there are 5 physical light sources: an area light + a spotlight, both animated with a fade curve and colour fade. The Spotlights poition is animated as well. And 3 area lights static in the light. Turning all animations off provided the same results.

its rendered without caustics, in interior mode. 30 samples with denoise at .4 . The Artifacts get worse with more samples though. And they do seem to not appear in product mode.


MacPro 2019

MacOS 10.15.4

Keyshot 9.3.14

AMD Radeon 580X Pro 

Intel Xeon

1 person has this question

Hello Jonathan,

Thank you for contacting Luxion.
We have noticed an issue in the platform with interior mode artifacts on Mac computers.
What type of KeyShot license are you using, HD, Pro, Education, etc?

Referencing your Ticket ID#:11042


Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
Yes we're still looking into why this is happening, but if you can send me a ksp of your scene it would help us figure out exactly what is going on.

Please send us your scene as a ksp file.
To save a ksp file:
  1. Open your scene.
  2. Go to File > Save Package.
  3. Name your file.
  4. Include Ticket number.

You may send it securely via our WeTransfer

After you send us the ksp, you can solve this issue by browsing to:
/Library/Application Support/KeyShot9

From here, find the file KS9Settings.xml. Delete this file and you should be good to go.
Let us know what happens.

Referencing your Ticket ID#:11042


Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

ive sent you the file.

the fix deleting the Settings.xml worked the first time for about 10 frames, the secodn time it didnt work at all: even the viewport got artifacts. 

thanks nonetheless :)

Hello Jonathan,

Does this happen on both of the computers you listed or any one in particular?
  • MacPro 2019
  • MacOS 10.15.4
If just a certain computer, what are the full specs of that machine?
  • Manufacturer (Dell, Toshiba, HP, etc..)
  • Windows/Mac OS version
  • Graphics Card model
  • Processor model
On the computer experiencing the issue. If deleting the KS9Settings.xml file is no longer working, I would recommend a full uninstall and re-installation of KeyShot 9.
Please try a fresh install using the full installer:

How to perform a fresh install:

  1. Uninstall KeyShot
  2. Make sure to createa backup and then delete the KeyShot resources folder
    • note: move it to the desktop if you wish to back up your resources
    • note: Make sure you do not have renders, files or resources saved anywhere else on the computer.
    • Mac Default:
      • /Library/Application Support/KeyShot
  3. Download and Re-install KeyShot using the links below.
    For this step, you’ll need the full installer(not the update installer).
    • You can find the newest version of KeyShot here.
  4. Go through the registration wizard, enter your license information, and KeyShot should be up and running.
Please let me know how this works for you.

Referencing your Ticket ID#:11042


Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
Thanks Jonathan,
As of now, if deleting the KS9Settings.xml does not solve the issue the only way around this is to not use Interior Mode when rendering.

We are currently looking into this case and will have this solved as soon as possible.

I apologize for the inconvenience this has caused you. Thank you for your patience while we work on this matter.
If there is anything we can do for you, please let us know.

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

I reported this april, 3 months ago. For a big this serious I find it unacceptable that it has not been fixed.

2 people like this

bug, not big...

Hello Jonathan,

I am following on this issue. 
Were you using the sun and sky environment when you come across this issue?

Referencing your Ticket ID#:11042


Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
Hi, No it was using a physical spotlight and regular hdri, and also using an hdri only.

This has also been happening to me on my 16" Macbook Pro Catalina 10.15.5 with 2.4ghz 8 core i9, 32gb memory, AMD 5500M 8GB running Keyshot 9.3.14. 

It also happens with 1 model with 1 body, simply imported with the startup HDRI and simple plastic material. It also exports like that in the final render as well.

I don't know if I'm just looking for patterns but if I restart Keyshot/ the laptop and wait for the fans to stop spinning, it works ok until the fans are at full speed again? 

It happens intermittently from 3 samples when I export the final image. In a queue of several renders, some might be ok but some will have the pattern. In the viewport it only kicks in around 30 samples.


This has also been happening on my 2019 Macbook Pro running Catalina 10.15.5

2.4GHz 8 core i9


AMD Radion Pro 5500M 8GB 

This is after deleting the xml file as mentioned above. In viewport it kicks in around 30 samples, but in exports, it starts at 3 samples. 

This is a single body model with a simple plastic material with 0.1 roughness


1 person likes this

Hej Erik, 

Is there any progress on this issue whatsoever? 

I have seen multiple others encountering this issue and i could also replicate it on EVERY Mac i tested it on, and usually i had not to wait long for this to happen.

The machines were multiple 2019 16" MacBook Pros, a 2014 MacBook Air, 2020 iMacs, iMacPros as well as 2019 MacPros.

But it does not seems to happen in windows at all right?

Its an issue that seems t be around since early April, which makes it now nearly half a year.

And it seems to affect the entire Interior Mode, so basically half of keyshot. 

Hi Jonathan,

You are correct that it only effects Mac and only in Interior Mode. The problem is it does not effect all Mac computers either, so it has been difficult to pin down the source of this issue.

But it is a critical case for us.

If anyone who is still experiencing this issue can provide us with a copy of their KS9Settings.xml file, it would help us find a common denominator. If you are willing, please send this file to under the title 'Artifacts-Mac'.

Thank you for your help and patience in investigating this issue.


Hi Erik,

I just have sent you my KS9Settings.xml file.

I just tried to render a interior scene again  that I have rendered some days ago, but today I got the artifacts - it's like gambling

(1.21 MB)
Login to post a comment