Start a new topic

Bip-Export from Solid Edge 2019 ignores correct unit

Hello,


If I export a Solid Edge file that has been generated using MMKGS (Millimeters, Kilogram, Seconds), the file is incorrectly scaled to meters. Do I take this issue up with GTAC, or is this something you guys at Luxion could look into?


There is an additional issue regarding the import-feature:

if I have rotated the object within the file to +90 degrees and reimport updated geometry as depicted in the screenshot, the geometry gets turned back to -90 degrees. As far as I am concerned, orientation should be untouched by this setting, or should be an additional checkbox. I have been fighting with this issue for quite some time, I would be very grateful if the new release could somehow have this minor problem solved ...


Thank you very much in advance!


Best regards,


Bastian

bip
(545 KB)
par
(696 KB)

Hello Bastian,

Thank you for contacting Luxion,
When importing, is the geometry correct and just using  the wrong units or is it completely messed up?
Just to confirm you experience this issue when importing directly to KeyShot and not through the plugin. Is that correct?

When changing the rotation to +90 and importing it, is the original scene already opened in KeyShot? Is this using the plugin or when imported directly to KeyShot?

Referencing your Ticket ID#:18028

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

Hi Erik,


great to have such short response-times. I really appreciate your efforts!


When I import the geometry itself is correct, just the units are messed up. This is using the "save as bip" function out of solid edge, rather than using the plugin itself. I would prefer using the plugin but we experienced random update issues that forced us to deactivate the plugin interface.


Concerning your second question: 

Keyshot is already running using the original scene. I rotate the object +90° within keyshot, and then reimport the geometry via file ->import ... for the abovementioned update-issue reason 



Best regards,


Bastian




Hello Bastian,

Thank you for contacting Luxion.
Its been my pleasure. Thank you for the information.
In regards to the Solid Edge plugin, that unfortunately will have to be addressed by Solid Edge as they designed the plugin. We do not have the coding or work on it.
If you are using a Windows PC, is 'cached geometry' turned on?

If I change the rotation of the object within Keyshot to +90 deg and reimport the geometry, the original scene is already opened, again, importing directly from within KS for the aforementioned reason. 

  • That is actually by design. When importing the old geometry, basically you are overwriting what was previously changed in KeyShot. The best way to look at is is your loading a backup, in case any mistakes were made when editing in KeyShot. The plugin should work in a way that you 'update' the geometry instead of overwriting everything, but unfortunately the problems you are experiencing with the plugin will have to be addressed by Solid Edge.


Referencing your Ticket ID#:18028

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

Hi Erik,



where do I find the "cached geometry" setting?


-> I'll see about contacting Solid Edge about the units issue.


with regards to the rotation issue:

I think I may have been a little unclear as to what is going on:

I save the original file under a new name in Keyshot. Then I rotate the object within the keyshot file. then I save the file to the new name. Then I import the original file from within that file, stating that I'd like to update geometry only.


Until now, I was assuming that this operation should only update the geometry of the geometric object itself, and at best, the positioning of encapsuled objects therein, not the positioning of the updated geometric object within the environment space of the (renamed) file. Is this an erroneous assumption?



Best regards,


Bastian




Login or Signup to post a comment