Start a new topic

Bug using LiveLinking from Rhino 6.0 SR31: Wrong orientation of model (Z=Up)

Windows 10, Intel i7, 32 GB RAM, SSD, RTX 2070-8 GB, 1920x1080 HDMI.

Bug using LiveLinking from Rhino 6.0 SR31: Wrong orientation of model (Z=Up) upon adding new NamedViews=Cameras in Rhinoceros 6.0 SR31 and then using LiveLinking plug-in to update the scene in KeyShot 10 (Nov. 2020)

Thank you for contacting Luxion .
I have our team looking into this now.
Either myself or another Support representative will reach out to you as soon as possible with an update on this issue.

Thank you for your patience while we look into the matter.

Referencing your Ticket ID#:21189


Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
Hi Erik and Co. I just downloaded and installed the updated “live-link” to SketchUp 2021, which is now officially supported. Thankyou for that update. Unfortunately version 1.2 had exactly the same bug as the “live-link” to Rhino 6/7. Please get in contact with me, so this issue can be solved and the “live-link” actually work (!!) and update new cameras/scenes correctly with due respect to the Z-up Y-forward standard in SketchUp and Rhino.
Hello Erazmataz,

Thank you for contacting Luxion.
You mentioned that the Sketchup 2021 plugin v1.2 is having the same issue as Rhino 6/7. 
Is it the exact same issue or similar to the Rhino Z axis problem?

If you could provide us with the same steps to reproduce the issue, along with a sample CAD file you've seen the issue in I will have our team take a look.

You may send it securely via our WeTransfer site.

WeTransfer link here.

Please make sure to include the following in the message field for your upload:

1. Your Ticket ID:       21189
2. The Case Subject: Bug using LiveLinking from Rhino 6.0 SR31: Wrong orientation of model (Z=Up)
3. Support Agent:       Erik Williams

This will allow us to track your files in our system.

Referencing your Ticket ID#:21189


Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
1) Create a SketchUp model with one or multiple Scenes (Cameras). 2) Export via LiveLink to KeyShot 10.1. 3) Inspect the result: Everything is OK and the Scenes from SketchUp is available as Named Cameras in KeyShot as expected. 4) Return to SketchUp and add a NEW Scene (Camera) and update the LiveLink. 5) The result in KeyShot 10.1 show that the new Scene(s) are creating Camera(s) with a flipped YZ orientation in KeyShot. THIS US THE SAME PROBLEM AS IN RHINO 6/7

Hello Tim,

This issue should be solved for the latest version of Sketchup.

Are you experiencing this issue on Sketchup 2021 or are you testing on Sketchup 2019?

I’m using SketchUp PRO 2021 and KeyShot 10.1.28. The issue had NOT been resolved and the problem is the same in Rhino 7.4: First transfer is OK and any following will make all your linked “Cameras” unusable since the orientation of Y & Z are flipped.
Hello Tim,

The files you sent in Freshdesk ticket # 31144 were for Rhino and not SketchUp.

But the Rhino 7 plugin should have this issue solved. The plugin website seems to still have version 1.0  available for Windows. Are you certain you installed the keyshot10_rhino_1.2.rhi?

To make absolute certain, you can redownload the latest version of the Rhino7 plugin for KeyShot 10 at

If you can provide the sample CAD files for Sketchup 2021, I will check there as well.

I noticed that with the rhino files you sent us, once  everything is imported to KeyShot changing cameras will reset the axises  to the correct positions. 
Is that true for you as well?
Hi again. Let’s focus on Rhino 6/7 first and postpone the SketchUp Issue for later... I have Rhino 6.0 SR34 and Rhino 7.4.21078 installed on my Windows laptop. Using the KeyShot LiveLink plug-in 1.0 it was possible to export to KeyShot with the initial NanedViews/Cameras the first time. Any additional Cameras added later was NOT respected the correct YZ-acis in CAD. Using the 1.2 (RHI-file on the website) it is ONLY working in Rhino 6 and No longer in 7. The problem with the YZ-axis for added Cameras is the same in Rhino 6 using 1.2. The only change is, that the original Rhino Cameras are no longer messed-up now...
Is it possible to get a call from your Office in Denmark to +45 9176 2131. // Best Tim

Hi Tim,

Thank you for the files. After going over Freshdesk  ticket # 31319, it seems after downloading the Rhino 7 plugin the old  version is still being used. Your plugin properties should look  something like this:

Your Registry path and file name are both leading to different locations, which would explain why only Rhino 6 is working.
You can fix this a few different ways.
You can edit your Registry by pressing the Windows key and enter 'reged' to open the Registry Editor.

After opening the Registry Editor, browse to either:

  • Computer\HKEY_CURRENT_USER\SOFTWARE\Luxion\KeyShot 10
  • Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Luxion\KeyShot 10

Confirm that the Resources lead to the same file-path as ResourceFolder.

If not, you can edit this by right-clicking on Resources and selecting 'modify'.

The other, cleaner option would be to get a fresh start and uninstall all versions of Rhino and  KeyShot plugins installed on your computer. This will clear any cached data and should get version 1.2 installed correctly on your computer.

If you are still running into issues with Rhino 7 and the  Rhino 7 plugin, let me know and we can schedule a remote session to see  what exactly is going on.
Hi Erik. I deleted a sub-folder with a reference to “Rhino 5” in the KeyShot plug-in directory (which was installed via the *.rhi installation (drag’’n’drop to Rhino UI). After deleting that folder I could manually install the plug-in in Rhino 7 using the *.rhp-file. This solution worked and now both Rhino 6 and 7 has a plug-in with the exact same YZ-axis bug using version 1.2


Thank you for the update Tim!

Login to post a comment