Start a new topic

Render errors with new 3080Ti card in Keyshot 9.3


I had this error today with my new machine using a brand new 3080Ti graphics card what's wrong ? All works ok when I use the i9 CPU but with the NVIDIA 3080Tii GPU I get these errors

(19:35:13) Pipeline create failed: COMPILE ERROR:

Info: Pipeline has 16 mok����

(19:35:17) Saved render to C:/Users/Utilisateur/Desktop/test.7.png

(19:37:31) Saved render to C:/Users/Utilisateur/Desktop/test.8.png

(19:37:39) Optix error: 7251

Device : NVIDIA GeForce RTX 3080 Ti

(19:37:39) Pipeline create failed: COMPILE ERROR:

Info: Pipeline has 16 module(s), 34 entry function(s), 38 trace call(s), 0 continuation callable call(s), 271 direct callable call(s), 6750 basic block(s) in entry functions, 110131 instruction(s) in entry functions, 0 non-entry function(s), 0 basic block(s) in non-entry functions, 0 instruction(s) in non-entry functions

Error: Symbol '__intersection__curve_1_0x30f8778e47c91912' was defined multiple times. First seen in: '__intersection__curve'

Error: Symbol 'worley_poisson_table' was defined multiple times. First seen in: '__raygen__pathtrace'

(19:37:39) Pipeline create failed: COMPILE ERROR:

Info: Pipeline has 16 mok����

(19:37:42) Saved render to C:/Users/Utilisateur/Desktop/test.9.png

thanks for your help,


Best Answer

New studio driver seems to have finally fixed this FYI.

Hello Hans,

Thank you for contacting Luxion .
There is currently an issue with the latest drivers and KeyShot 9.  At this point we would recommend returning to an older driver version I believe it would be 466.77.  You will need to select custom install for the drivers and perform a fresh installation of the game ready drivers.

I would also recommend performing a fresh installation of KeyShot 9 using the full installers: here is the download link for that.

We have reached out to Nvidia regarding the issue and hope to have some information on this shortly. 

Referencing your Ticket ID#:42049

You are able to check the status of your ticket by visiting your ticket portal by clicking here.
We would recommend bookmarking the page as you can also see if any responses were sent to you or notes applied.

Justin Adams
Support manager
Luxion Inc
15143 Woodlawn Ave
Tustin, CA 92780

Hello Justin,

thanks so much for the quick reply, I'll test this out, the new card is really fast for rendering so I hope this will work

thanks and greetings,


Hello Justin,

I installed the 462.65-desktop-win10-64bit-international-nsd-dch-whql-rp driver and now it works perfect, didn't had to reinstall Keyshot 9. Amazing speed for rendering 0,46sec for a 1920x1080px image wow !!!

thanks again for help hope the newer Nvidia drivers will work again with Keyshot,

kind regards,


There could be elements of the older scene like legacy textures or unsupported features that can cause this to happen.

You can try to open it in KeyShot 10, save the KSP, navigate to file, hit new and select import the file.

Once this is done try to use GPU.

As stated there just might be unsupported elements in the older scene. 

Thanks Justin, I don't have Keyshot 10 yet, I wanted to update when 11 comes out so for now I have to do with v9. It seems to work right now which is strange I had a few crashes and then it started to work again. I'll do more tests tomorrow and let you know how it works out. 

thanks, Hans

Hi Justin , I have a serious issue here, I managed to work with the GPU and safe the file but now when I try to load or work with a project for a client it crashes keyshot most of the time can't even work anymore, this is not good. It worked perfectly with the latest nvidia drivers except GPU export rendering, and why does the new driver cause these export issues ... I'm stuck for now to use cpu only but with a 1600$ graphics 3080Ti card this is really frustrating



Hey Justin,

if you have workaround for this that would really be help full as this is driving me crazy, it worked well for a few hours and crashing every time I switch to GPU render now it's not the render itself its the switching that causes the crashes in Keyshot thanks, Hans 

You can try to delete the settings.xml file, this will reset KeyShot and remove and corrupted settings:

Windows Instructions:

1. Go to either one of the destinations below:

  • C:\Users\Public\Public Documents\KeyShot #
  • C:\Users\YourUserName\Documents\KeyShot # 

2. Look for KS#Settings.xml file and delete that file

3. Relaunch KeyShot. DO NOT migrate any settings from older versions of KeyShot if it asks again.

Thanks Justin will check this out. 

For now I seem to have found a solution I need to test more but I managed to avoid the crash this way:

1. select 85% CPU usage instead of the initial 100%
2. then switch to GPU 

not sure why ... I'll test more and also your method,

thanks a lot,

kind regards,


Hi Justin, yesterday everything worked fine then this morning I couldn't open my project saved with GPU anymore, neither your or my solution worked, really strange, not sure how to adres this I need to finish jobs and am very excited with the new performances of my machine but I cant work this way 



P.S. new workaround that seems to work is to open a demo file activate GPU and then open my project, really strange, is there any news if Nvidia is going to update their drivers soon addressing the render issues as I didn't had any issues with their latest drivers working in realtime besides the export crash. 


New studio driver seems to have finally fixed this FYI.

Login to post a comment