Start a new topic

Studios not retaining settings

This is a long-standing issue. However it's still persisting and very annoying. Often after opening a file (previously saved) I return to find I need to update many of the studio settings. Especially studios that have multiple active model sets. Environment and camera seem to be remembered, but I'm also needing to specify the model set often. I'm not using multi-materials so can't comment on the state of that at the moment. 

Ver. 11.1 Beta. Build 33

1 person has this question

Hello Will,

Thank you for contacting Luxion Denmark Support.
Yes we've noticed that opening an older ksp with a saved studio configuration in KeyShot 11.1 will result in some issues with the previously saved studio configuration.
Our team is looking into this now and hope to have it solved before its official release.

Referencing your Ticket ID#:58722

You are able to check the status of your ticket by visiting your ticket portal by clicking here.
We would recommend bookmarking the page as you can also see if any responses were sent to you or notes applied.

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

2 people like this

Hello Erik,

Could the KS team prioritize to fix this issue? I tried to redo the configuration and save the file as Keyshot 11 cannot not solve problem and this is unacceptable.

The Studio problem is existing since KS 9 & 10. It usually alter some configurations by itself when importing new CAD file or duplicate model set. Sometimes it will choose other environments and sometimes it will select another model set or camera. It happens randomly and it's so unstable that I need to keep checking every Studio after importing files or duplicate parts. This problem is annoying and time consuming especially if we're working on heavy geometries we need to wait the system to load and refresh!

Ver. 11.1.0 (Build 46)

Thanks in advance for the help!

1 person likes this

I have to agree that this is really disappointing and pretty unacceptable. This is the kind of bug that makes the software nearly unusable for any kind of job that relies on studios. Any update on this? 

3 people like this

Hi  I'm having this problem but with multi-materials.  I am setting up studios with all different model-sets, multi-materials, environments and cameras.  Everything will work fine then. I will configure all the studio then go back to the first studio and some of the materials are wrong.

It would be great if you could fix this asap as it is a the fastest workflow.

The scene was originally from KS10.

2 people like this

Jeez, I'm also here for this same issue. I built a scene in 11.0 yesterday, and today after sending 8 studios to the network rendering server they all came back wrong. 8 out of 8 studios had random (and incorrect) materials across all the images.

I stopped using Studios in KS10 due to these issue, and I can't believe it's still unaddressed. Looks I'm back to post-it notes to manage my files :/

2 people like this

I was dealing with this issue also in KS10, for me it happens while working on open file like when i duplicate a studio and tweak some settings to it, it will change not only the setting of original studio but also on random studios. once i habe about 180 studios, it was a lot of fun to work with keyshot on that project...

I have also been running into this same issue and I am updated to 11.2. Every studio has the same camera and environment so I am not sure if those settings are being lost but the multi materials in every studio I've created is changing to whatever changes I make outside of studios. I have all the boxes ticked on the studios to save those settings. I am not sure if this problem occurred when I opened a file in 11.2 that had been previously saved in 11.1. Please address this issue as studios saves me a massive amount of time. Thanks!

... same problem here. Made a lot of studios ..... open the file and all the studios are gone!

This is maybe a quick fix when all the studios are gone in your file. Make a new file and import the file with the missing studios … (in my case) all the studios are back! Hope this helps!

Thank you Remko, if that works that is great!

1 person likes this

I've been having this issue since Keyshot 9. How has this not been fixed yet? It's a major problem, especially for professional work where time is crucial. The file I'm working in right now won't retain the image style setting for any of the 15 studios so every time I select a new studio I have to reset the image style. 

Keyshot team - when will there be a fix for this?

1 person likes this

I agree it is very frustrating. I am currently working on a file where all of the studios are gone when I open the file. I import the corrupted file into a new file and all of the studios magically reappear. I have to do this every time I close and re-open the file. Luckily the information is retained but a pain none the less. Typically files will not retain certain studio information but all of the studios missing is a new one for me. 

I just built a file with 30 Studios and different multi-materials. Closed, opened the file, everything was still there. I went to batch render and sent all studios... every single render was the same. I went back to my file, every studio has the multi-materials checkbox now unchecked, losing dozens of hours of work. I went back to 3 different versions of my file, SAME THING IN EVERY FILE. I've been spending the last 4 hours setting up a studio with multi-materials and rendering them each one at a time. This is beyond insane that this feature that is mission-critical can be this broken. This isn't some feature we like to use, it is the very life blood of using Keyshot vs physical photography. 

We need this fixed ASAP. 

It's no wonder one of my team members started using the configurator wizard instead of studios because they're so buggy, I posted this same problem about a year ago on the forums and the fix was to check and uncheck the multi-material box on a recently opened file, that isn't working anymore. KS 11.2.1 now instead adopts whatever the multi-materials states are live as the check-box's settings. 

What do we do? I'm up against an immense time crunch. 

I was having issues with files made in older versions of Keyshot not saving my multi-materials in Studios. I just started a brand new file in Keyshot 11 today. Studios was working until I closed and reopened my file - none of my multi-material settings were saved (the multi-materials box was checked.)

Studios is critical to my workflow, and I cannot redo my work every time I reopen a file. I am at a loss of how I'm supposed to do my job this way

Login to post a comment