Start a new topic

PSD file fail opening in Affinity photo after update to Keyshot 11.2


I don't know if anybody else got this problem, but after updating to KS 11.2 it the exported psd file 67 MB including the layer passes won't open in Affinity Photo 1.10.5 on my Mac OS 12.4 Monterey.

Previous versions of KS worked absolutely fine

The error message is the the file type is unknown.

Big question now:

Is the KS 11.2. update responsible for this?

thank dpi for the help


2 people have this question


it seems to be definetly a problem of Keyshot, as I asked a friend if he ist able to open the .psd file directly in photoshop.

And surprise surprise. Photoshop can open the file.

And after "save as ..." the file in photoshop without a even touching it after opening, I was also able to open this "save as..." psd file in Affinity photo.

So it looks like Keyshot has done something slightly different when exporting as .psd

Guys at Keyshot:

PLEASE, PLEASE give us a note, if you are going to fix this bug.

Thank you


I do have the same problem.

.PSD files exported with KS 11.2.0 won't open in Affinity Photo anymore. "Failed to open file. File type not supported" Previous versions of KS worked well. And there was no update to Affinity photo.

No difference if packing the render passes right into the PSD or not, or choosing 16 or 32-bit PSD or turning alpha on or off. 

Really shitty since a whole render queue of images is now wholly worthless and my workflow ruined. 

could you please look into that if KS is responsible?

kind regards

Login to post a comment