Start a new topic

How can I use GPU based tendering with NVIDIA Quadro M2000M on Keyshot 11?

I am using a Zbook G3 i7 6th generation. I want to run GPU based rendering on my dedicated graphic card NVIDIA Quadro M2000M but it is not showing me the option to use it. I want relevant help.


Hello Bilalhxn99,

You can try updating you graphics card's drivers.

If you are using an Nvidia graphics card there is an other option to get around the issue.
How to set the Nvidia Graphics-card as preferred GPU
1. Open the Nvidia control panel.
2. Go to Manage 3D settings.
3. Go to the Program Settings.
4. Select KeyShot from the Drop-down.
5. If it is not available add the KeyShot.exe manually by browsing to it below.
  • C:\Program Files\KeyShot #\bin\keyshot.exe
  • %USERPROFILE%\AppData\Local\ in the KeyShot #\bin\keyshot.exe
6. Select your Nvidia graphics card under preferred graphics processor.
7. Click Apply and restart KeyShot.

Bare in mind that there may be instances where Windows will override the Nvidia Settings, so please confirm these changes have been saved before proceeding.

Referencing your Ticket ID#: 71960

You are able to check the status of your ticket by visiting your ticket portal by clicking here.
We would recommend bookmarking the page as you can also see if any responses were sent to you, or notes applied.

Justin Adams
Support manager
Luxion Inc
15143 Woodlawn Ave
Tustin, CA 92780

1 person likes this

Hi Justin, 

I have already set NVIDIA as the preferred graphics card but it has not resolved the issue. when I start keyshot, the GPU button shows for a second and then instantly disappears. Now I am trying the latest drivers from the link that you have shared with me. will write to you after installing the drivers.

Login to post a comment