Start a new topic

Keyshot 11.2 - PSD file can't open in Photoshop

When opening files from Keyshot 10 in KeyShot 11.2, I have discovered that KeyShot 11.2 produces renderings in PSD format that can't be opened in Photoshop. The error seems to be related to the layer naming when using Danish letters æ, ø, å (the last three letters in the Danish alphabet) as part of the layers name.

It's not an issue in KeyShot 10. I don't know yet, if it is also an issue when creating KeyShot 11.2 files from scratch using these letters in the layer naming.

The error message is attached.

I'm using a Windows 10 platform.

I haven't tried if it also is an issue using the Mac platform.

BR Jens

Hello Jens,

Thank you for contacting Luxion .
You are correct, there is an error in how we export these characters to psd format.
Our team is looking into this now and we hope to have it solved in the KeyShot 11.3 release, scheduled for late October.

Thank you for bringing this to our attention.
We will have this solved as soon as possible.

Referencing your Ticket ID#: 73242

You are able to check the status of your ticket by visiting your ticket portal by clicking here.
We would recommend bookmarking the page as you can also see if any responses were sent to you, or notes applied.

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

I have the same problem with the version 11.2.1. (Build 5) both Apple Silicon & Intel versions. I am running those in Mac Studio Max. So cannot open PSD-files on Affinity Photo.

SInce I am not paying any more for the Maintenance, and not eligible for coming 11.3, what is the latest KeyShot version, which works with .psd files? Are my saved .bip files backwards compatible to the working KeyShot version?

... and where can I download the version, where .psd files work? I guess it is 11.1. I do not have it any more on my server.

Login to post a comment