Start a new topic

Materials disappearing from tree structure but still in the library

 KeyShot 11.3.2:

Is there a way to restore a default structure for the tree under the Materials tab in the Library panel?

 I'm experiencing a peculiarity where specific materials, and in some cases an entire material category, disappear from the tree after I've applied it to parts in a model.

For example, I applied Brass-Brushed to a few parts by navigating to it in the tree under Metal > Brass. Then I go back to it later in the tree and brushed brass is absent. It is still in the library but the only way to find it is to search from the top "Materials" level.

I experienced similar behavior after applying a few instances of Stainless Steel - Rough, then after a while the entire Stainless folder was gone from the tree. Again, all the SS types are still in the library, but have to find them by searching from the top level.

This is very inconvenient and I can't find a way to regenerate the materials tree to the default structure that is was in originally. The Refresh button at the top of the list does not fix it. Restarting KS doesn't make any difference. I can't find any mention of this in the documentation or help resources.

For some reason the tree organization structure is breaking and there doesn't seem to be an apparent way to fix it.

Thank you to anyone that can help me out.


Can probably disregard my original post. Searching around on another topic, I stumbled across the same issue in the Bugs and Crashes forum section. It appears this is a known bug reported about 4 months ago. Hopefully it will be fixed soon.

Hello Visiblegold,

Thank you for contacting Luxion .

Yes this issue will be solved in the next major release, but if you save the scene, close and restart KeyShot the library should be restored.
We apologize for the inconvenience. We will have this solved as soon as possible.


Referencing your Ticket ID#: 82373

You are able to check the status of your ticket by visiting your ticket portal by clicking here.
We would recommend bookmarking the page as you can also see if any responses were sent to you, or notes applied.
 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

I have a similar problem, Iam a Keyshot 11 user, I was apliying a plastic material to an objects, but I drag the material to the proyect window, and now there are not plastic material on the preview materials window or nider on the materials tree, so, Ihave to reinstall Keyshot? or I have to wait to the next update?


I have the same trouble. It is very frustrating when I am are trying to meet a deadline and I cannot find where the Metal, Paint, or Contour material folders have gone to this time. Unfortunately, restarting KeyShot does not work for me. I have to go into the KeyShot 11 folder/Materials find and reorganize the folders, but it is only a matter of time before it happens again! The material SEARCH feature has also not been working for a long time. Are you saying we need to wait till Keyshot 12 to have these issues resolved?

Due to the severity of this issue, we have added this and a few others to a patch release early next week at the latest.

Once it is release, you should see the option to update when starting KeyShot.


Thank you for your patience with all of this.

Give it a try once it is ready and please let us know if you are still experiencing this issue.


Med Venlig Hilsen / Best Regards,


Erik Williams

Customer Support Specialist

Login to post a comment