Issue
When trying to use certain KeyShot plugins you may run into an error that looks similar to the one below.

Environment Details
- KeyShot | KeyShot Plugins
- This can happen to any version of the KeyShot and the KeyShot plugin.
Cause
- The would-be that KeyShot is installed in a different location than the Plugin is installed.
- This can happen as KeyShot installed "Just for Me" will install into a different directory.
- The install can end up at "C:\Users\UserName\AppData\Local\KeyShot ##\
- The plugin will normally install to "C:\Program Files\KeyShot ##\Plugins\
- This will cause it to be unable to find the bin folder in the root KeyShot folder hence the API error.
- This can happen as KeyShot installed "Just for Me" will install into a different directory.
Resolution
The quickest way to resolve this would be by following the steps below.
- Uninstall KeyShot from the computer.
- Uninstall the KeyShot Plugin.
- Reinstall KeyShot.
- Right-click the installer and select Install as Administrator.
- Select the option Install for everyone using this computer.
- Go through the installation Wizard but don't change any folder locations.
- Click Finish and Activate Keyshot.
- Reinstall the KeyShot Plugin affected.
- Launch the CAD software and test the Plugin to see if everything is working correctly.
- Contact Support if you still have issues with any errors and screenshots.
Additional Resources