Issue


After installing KeyShot and starting it up for the first time, the following error occurs:


Cannot open environment image "startup.hdr"




Environment Details


  • KeyShot
    • Any versions



Cause


  • Windows Defender Firewall hindered the KeyShot installation and blocked it from opening.



Resolution


Solution A


Temporarily disable the firewall or Windows Defender to confirm if it works. If it does, then contact your internal IT to assist in allowing KeyShot to run without being blocked.

Solution B


While the firewall is disabled, reinstall KeyShot with the "Run as Administrator" option.


How to perform a fresh install:
  1. Uninstall KeyShot.
  2. Make sure to delete the KeyShot resources folder.
  • Note: Move the folder to the Desktop if you wish to back up your resources.
  • Windows Default:
    • C:\Users\UserName\Documents\KeyShot or
    • C:\Users\Public\Documents\KeyShot
    • Delete C:\ProgramData\Luxion\KeyShot folder
    • Delete C:\Users\%username%\AppData\Local\Luxion\KeyShot folder
  • Mac Default:
    • /Library/Application Support/KeyShot
  1. Download and Re-install KeyShot using the links below.
    For this step, you’ll need the full installer (not the "update" installer).
  • You can find the newest version of KeyShot here.
  • You can find older versions of KeyShot here.
  1. Right-click the installer and choose the "Run as Administrator" option (if on Windows). Otherwise, go through the registration wizard, enter your license information, and KeyShot should be up and running.