Issue
When activating your subscription license, the following error appears when trying to Sign in:
Failed getting endpoint. Make sure you are connected to the Internet.
The KeyShot Log Window may show the following as well:
Environment Details
- KeyShot
- Version 11
- Version 2023
- Subscription License Key
- Internet Web Browser
- Chrome
- Firefox
- Safari
Cause
- Security Internet Browser settings or Firewall settings.
- Cyber security software such as Zscaler sometimes fails to see the SSL certificate from keyshot.
Resolution
Solution 1
Change the default Internet Web browser on your machine. For example, if your default Web browser is set to Firefox, change it to Chrome or Safari.
- Close KeyShot.
- Change the current default browser to another browser:
- Open KeyShot and re-test the issue.
Note: The links above will navigate to a non-affiliated site of Luxion. Consult your IT admin on how to change the default browser settings on your OS.
Solution 2
Add the following KeyShot URLs to the Firewall Whitelist for the organization:
- *.keyshot.io
- *.key.account.io
- *.keyshot.com
- https://login-configuration.keyshot.com
- https://login.keyshot.com
- https://app.keyshot.com
- https://cognito-idp.us-east-2.amazonaws.com
Note: Contact your Network IT department to assist in adding these entries.
Solution 3
Clear cache in KeyShot.
- In KeyShot, go to File > Sign out and exit. (This is important to disconnect any "remembered" users.)
- Delete the KS12Settings.xml file to clear any cached data.
- If installed as "Just for Me", go to - C:\Users\<username>\AppData\Local\KeyShot12
- If installed as "For Everyone", go - C:\Users\Public\Documents\KeyShot 12
- Restart KeyShot and re-test the issue.