Issue


Users may report they are "cannot connect to update server. please try again later" message when updating KeyShot for example from a over office network




Environment Details


  • KeyShot 
    • 2024.1 | Any versions



Cause


  •  There could be a few things that could be blocking your ability to check for updates to our upgrade server and they are as follow.
    1. Connection to the upgrade server is blocked by network on your end.
      1. The port number  may not be able to reach out to the server.
    2. Connection to the upgrade server may not be reached based on the version of KeyShot you have.
      1. This could be that you had an earlier version of KeyShot that was considered a beta and that was blocked off.
    3. If your KeyShot is installed on your computer by your IT team remotely and they have the Update portion disabled it will not allow you to check for updates. 
      1. Certain companies have a script that runs the installation or a center location you can install from the script may have update disabled because the IT team likes to manually make sure things work before releasing updates. 



Resolution


These settings here are within your KS##Settings.xml located in your resources folder and can be changed at any time. The settings below are to not allow update checks for newer versions. 

<disableUpdate bool="true"/>
<enableAutoUpdate bool="false"/>
<nextUpdateCheck>203934</nextUpdateCheck>

The settings below are set to allow checks for KeyShot to look for updates. 
<disableUpdate bool="fale"/>
<enableAutoUpdate bool="true"/>
<nextUpdateCheck>203934</nextUpdateCheck>

The link below will also have the current version released available at all times so if you are not able to get it through KeyShot you are able to manually download it.